WooCommerce 3.7

WooCommerce 3.7

Как и прошлая версия, выпущенная в апреле, WooCommerce 3.7 сфокусирован на повышении производительности при добавлении новых продуктовых блоков WooCommerce и улучшении существующих. Это обновление также повышает минимальные требования к версиям PHP и WordPress для оптимизации производительности и безопасности магазина, рассмотрим это подробнее.

После всестороннего тестирования с популярными расширениями и темами на нескольких хостах, команда WooCommerce добавила поддерживаемые обновления для нескольких реальных клиентов на тестовых сайтах.

Что нового в версии 3.7?

Блоки продуктов WooCommerce

Блоки продуктов позволяют создателям магазинов легко размещать информацию о продуктах в постах и страницах, объединяя контент с коммерцией.

Улучшения и дополнения включают в себя:

  • улучшенную маркировку блоков для более легкого обнаруживаемости;
  • новый инструмент Focal Point Picker для блока избранного товара
  • новый список категорий товаров;
  • новый блок избранных категорий, позволяющий вам показать категорию и ссылку на ее архив;
  • новый блок товаров по тегам;
  • поиск продукции в блоках «Избранный товар» и «Ручной подбор продукта» стал быстрее — вау!

Для получения доступа к этим новым блокам, вам нужно либо иметь WordPress 5.1+ или установленную последнюю версию плагина редактора Гуттенберга.

Повышение производительности

Это обновление может похвастаться несколькими изменениями «под капотом», такими как ускорение страниц, где извлекаются данные комментариев (например, отзывы о продуктах, и комментарии под постом и страницы администратора). Эти улучшения гарантируют, что WooCommerce работает быстрее, чем когда-либо.

Новые минимальные требования к PHP и WordPress

WooCommerce 3.7 также увеличивает минимальную поддерживаемую версию PHP до 5.6. Это делается не только из соображения безопасности, но и для того, чтобы воспользоваться доступными функциями и функциональность, и предложить наилучший опыт для магазинов. При работе с последней версией PHP магазины стают также быстрее и безопаснее.

Так же была увеличена минимально необходимая версия WordPress до 4.9 — скорее всего, в недалеком будущем она увеличится до WordPress 5.0.

В WooCommerce 3.6.5 добавлены элементы обновления, указывающие пользователям на документацию, чтобы определить, есть ли у них самые последние и лучшие версии.

Магазины, использующие старые версии PHP и WordPress, не смогут обновиться до WooCommerce 3.7, пока не обновятся до минимальных поддерживаемых версий.

Дополнительные улучшения

В этом релизе есть еще несколько других тонкостей, исправлений и улучшений, включая возможность изменения формулировки «Спасибо» в сообщения электронной почты через дополнительное информационное поле и функциональность генератора новых купонных кодов.

 

Подпишись на новые статьи

Поделиться этой страницей
Поделиться в vk
Поделиться в facebook
Поделиться в twitter
Поделиться в pinterest
Поделиться в print